make deb and make tgz works now (RPM directory not up-to date)
[svn/Prometheus-QoS/.git] / debian / prometheus.debian
diff --git a/debian/prometheus.debian b/debian/prometheus.debian
new file mode 100755 (executable)
index 0000000..c17d10c
--- /dev/null
@@ -0,0 +1,17 @@
+#!/bin/bash
+
+arch=`dpkg-architecture -qDEB_HOST_ARCH`
+version=`grep VERSION= Makefile | cut -d = -f 2`
+package=`grep PACKAGE= Makefile | cut -d = -f 2`
+maintainer="gandalf <gandalf@arachne.cz>"
+control=debian/prometheus.control
+
+#patch -Nl <debian/prometheus.patch
+
+sed     -e "s/__ARCHITECTURE__/$arch/" \
+        -e "s/__VERSION__/$version/" \
+        -e "s/__PACKAGE__/$package/" \
+        -e "s/__MAINTAINER__/$maintainer/" \
+        $control > debian/control
+
+                               
This page took 0.108065 seconds and 4 git commands to generate.